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By Mark Andrews, Editor-in-Chief, Windows Secrets

With the information in this special report you can:

v Recover a crashed system in just 10 minutes using

System Restore
v When all else fails, access your crashed PC using Safe Mode
v Use the 3 essential fixes to repair a failed PC

There’s nothing worse than finding that a change to your system, such as a
new application being installed, leads to crashes, or even prevents your PC
from starting normally. Fortunately Windows has the answer, in the shape of
System Restore. System Restore should be the first thing that you try when
resolving serious problems with your Windows system, as it allows you to
reset your PC to a time when you knew it was last working, undoing the
harmful changes that are causing your PC problems, without risking the
integrity of your personal files. In this special report, | will explain how to use
system restore points to recover your PC from a serious crash or error state.
When you have mastered Windows System Restore, you will be prepared to
deal with a sudden PC failure.
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Discover the Hidden Capabilities of a Little-known
Windows Recovery Tool

System Restore protects your PC by backing up vital Windows files and
settings. These backups are called ‘restore points’ and contain all of the
information required to return your PC to a previous healthy state, by undoing
all of the changes that are causing you problems. There are two elements to
System Restore: file monitoring and restore point management. Both of these
functions are performed by a Windows service that is continually running in
the background to keep you protected. There are four types of restore point:

Restore Point Type Description

System checkpoint Automatically created every 24 hours while your
PC is running, or when first started. The computer
must be idle for a point to be created, that is, no
programs should be running, even in the
background, including anti-virus software.
Disabling and re-enabling System Restore will
also create this type of point, as will starting
Microsoft’s Backup Utility or installing an unsigned
hardware driver.

Program installation Automatically created before the installation of
most new software, if the software installer is
compliant with System Restore. For extra
protection, always create a manual point before
installing a new application.

Automatic update Created when Windows Update is activated, to
ensure that you can restore your system if the
Windows Update causes serious problems.

Manual update Created by the user via the System Restore
dialogue. You should create a manual restore point
before you make any major system change, using
the steps given on page 12.

Restore points are retained on a first-in-first-out (FIFO) basis, dependent on
the amount of hard disk space that is allocated to System Restore (usually
12% of the total), which means that when the space allocated to System
Restore on your hard disk is full, the oldest restore point will be replaced. You
should note that, while creating lots of manual restore points improves the
chances of disaster recovery, FIFO deletes older points that may later prove
invaluable. The number of points retained at any one time will of course be
specific to your set-up.
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Easily Recover Your System from Disaster Using
System Restore

If your PC keeps crashing, there are three essential fixes that will help you
undo the problem causing the crash, and get your Windows back on its feet.
Which fix you choose depends on whether or not you can get Windows
started up. Follow the chart below, in combination with the steps given in this
article, to select and apply the right fix for your problem.

Yes Fix 1: Repair a Crash in 10
Minutes with System
Restore

Does Windows start
normally ¥

Yes Fix 2: Cure Your PC from
Gan you boat In to Safe Mode When Windows
Sale Moda? Won't Start
S ——"

Fix 3: Emergency Steps to
Revert Your PC to the Last
Waorking Configuration

Working PC

Fix 1: Repair a Crash in 10 Minutes with System Restore

If you can start Windows, but the system is corrupt and keeps crashing, it
should be reverted to a previous working configuration. You can run System
Restore to do so:
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Windows 7/Vista

1. Click Start > All Programs > Accessories > System Tools > System
Restore.

2. Click Next (Windows Vista users select Choose a different restore
point and then click Next).

3. Select a restore point from when you know that Windows was working
properly and click Next.

4. Click Finish to revert to the settings stored in the restore point.

System Restors

Choose a restore point
System Restore will not change or delete any of your documents and the process is reversible,

Select the
restore point
that you want
to revert to.

Click the restore point that you want to use and then dick Next, How do I choose & restore point?

Current time zone: GMT Daylight Time

Date and T|me' Description
Install; Windows Update
Install; Windows Update
Click Next 01/09/2009 15 Insic.: Windows Update
t ii 31/08/2009 23:03: 14 Install: Windows Update
0 continue. 31/08/2009 11:22:12 System: Configured Evernote

30,/08/2009 22:04:24 Install: Windows Update |
30,/08/2009 21:52:44 Install; Windows Update
~_29/07/2009 10:56:40 Install; Windows Update

Show restore M
[ < Back\f Mext = ] [ Cancel
Revert your system to an earlier time using System Restore
Windows XP

1. Click Start > All Programs > Accessories > System Tools > System
Restore.

2. Select Restore my computer to an earlier time.

3. Click Next.
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4. On the Select a Restore Point screen, available restore points are
indicated on the calendar as dates highlighted in bold. Select a date to
display the available point(s) for that day.

5. When you have chosen and selected a restore point, click Next > Next.

Fix 2: Cure Your PC from Safe Mode when Windows
Won’t Start

If you can’t get your PC to run Windows, then you will need to boot your PC
into Safe Mode, and then run System Restore from there. To do so:

1. Restart your PC and as it starts tap (Fs) continuously.

2. Use the (1) and (3) keys to select Safe Mode from the options then
press [Enter).

3. As Windows starts in Safe Mode, you may see a prompt asking if you
want to use System Restore instead. In this case, accept the offer and
follow the instructions.

4. Follow the appropriate steps from Fix 1 above for your version of
Windows to run System Restore and restore your system.

Fix 3: Emergency Steps to Revert Your PC to the Last
Working Configuration

As we’ve seen, System Restore can be a lifesaver when Windows has
become unstable, allowing you to step back to a time when everything was
working without any difficulties. However, System Restore will only work when
you can start Windows.

Windows does provide another complimentary utility called Last Known Good
Configuration that should allow you to get Windows started if you can’t access
System Restore. You can revert to the last known good configuration as follows:

1. Re-boot your PC and hold down the (F8) key to access the Advanced
Options menu.

2. Use the (1) and (1) keys to select Last Known Good Configuration then
press (Enter).

3. Windows will be reverted to the last working configuration available,
undoing the changes that are harming your system.
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If Windows is then running but continues to have problems, you should run
System Restore (since you can now access Windows) and revert your PC to
an even earlier configuration. Last Known Good Configuration only
remembers the registry settings that were in use when Windows last started
correctly. It does not store any other driver or software installation information.

Crucial Tip: How to Deal with a Severe Virus Infection

By default System Restore is enabled in Windows 7, Vista and XP. Since it will
help you recover from serious system crashes, it should be left running, but
there is one occasion when you may need to turn if off: when your PC
becomes infected with a virus.

The problem is that the virus infection could be hiding inside your system
restore point, meaning your virus checker can’t remove it. If your virus checker
finds a virus on your system but is unable to remove it, then the correct
procedure is to disable System Restore, run your virus checker to remove the
infection, then re-enable System Restore.

To make changes to the System Restore settings, your current Windows user
account needs to have administrative privileges. To proceed:

Windows 7

1. Click Start > Control Panel > System.

. Click Advanced system settings > System Protection.
. Click Configure > Turn off system protection.

. Click OK > OK.

. Restart Windows.

. Run your virus checker to remove the virus.

. Repeat Steps 1 and 2.

0o N o o0 b~ W DD

. Click Configure > Restore system settings and previous versions of
files.

9. Click OK > OK.
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Windows Vista

1. Click Start > Control Panel > System.
2. Click Advanced system settings > System Protection.
3. Under Available Disks, untick each one of the listed hard disks.
4. Click OK.
5. Restart Windows.
6. Run your virus checker to remove the virus.
7. Repeat Steps 1 and 2.
8. Under Available Disks, tick the C: drive.
9. Click OK.
Windows XP
1. Click Start > Control Panel > System.
2. Click System Restore, then tick Turn off System Restore on
all drives.
3. Click Apply > OK to finish.
4. Restart Windows.
5. Run your virus checker to remove the virus.
6. Repeat steps 1 and 2.
7. In the System Properties dialogue, untick Turn Off System Restore.
8. Click OK.

Important: Create a Restore Point Before Any System Change

Whenever you install a new program (particularly one that you suspect is

not compliant with System Restore), it is a good idea to create a manual
restore point. Similarly, you should create a point of this type when you make
any potentially risky changes to your Windows installation. The procedure is
as follows:
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Windows 7

1. Click Start > Control Panel > System.
2. Click on the link System Protection, then click Create.
3. Enter a name for your restore point, then click OK.

4. Once the restore point had been created, click Close > OK.

Windows Vista

1. Click Start > All Programs > Accessories > System Tools >
System Restore.

2. If the User Account Control dialogue appears, click Continue.

3. Click open System Protection.

4. Under Available Disks, tick the C: drive.

5. Click Create.

6. Type an appropriate and memorable name for your restore point.
7. Click Create.

8. When the process is complete, click OK.

9. To close any open dialogues, keep clicking Cancel.
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System Properties 1 u

| Computer Name | Hardware | Advanced | System Protection | Remote

much disk space is required ¥

Jg You can use restore pairts to undo unwanted system changes. How

Select the C: drive fou can also use restore points to restore previous versions of files,

from the list of called shadew copies. How do | use previous versions?

available hard disks. _ L
System Restore helps you restore your computer’s

System Restore... "

system files to an earier point in time.

Automatic restore points

Click Create to \%e restore points automatically on the selected disks:
generate the
restore point.

Availabie Disks Most recent restare point |

M| ncal Disk () (System) 03/09/2009 19:25:55

L]

T~
Click Cancel "
when done. I
\ I

ouU can create a restore point right now for the
M Create.. | | |k
4
| oK~ Cancel || Aol
Create a manual restore point in Windows Vista
Windows XP

1. Click Start > All Programs > Accessories > System Tools > System
Restore.

2. Select Create a Restore Point and click Next.
3. Type a memorable name for your restore point.

4. Click Create > Click Close.

Troubleshooting: How to Undo a Restore Point that has
Not Helped

If the selected restore point is either not the one required, or does not improve
the stability of Windows, you may need to undo the restoration. To achieve this:

10
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Windows 7/Vista

1. Click Start > All Programs > Accessories > System Tools > System
Restore.

2. Click Undo System Restore, then click Next.

3. Review the changes to be made, then click Finish.

Windows XP

1.Click Start > All Programs > Accessories > System Tools > System
Restore.

2.At the Welcome to System Restore screen, click Undo my last
restoration.

3.Click Next.

4.You may see a message detailing the changes that System Restore will
make. Click OK.

5.0n the Confirm Restoration Undo screen, click Next.

6.When Windows restarts, the System Restore Undo Complete page
should appear. Click OK.

With the faulty restore point removed, try using System Restore to revert to a
different restore point.

Protect Essential Documents and Files from Being
Replaced by System Restore

Every restore point includes a copy of the latest state of the Windows registry.
Beyond this, it is useful to understand just what System Restore is monitoring.
Obviously, you don’t want System Restore to replace your documents, emails,
image files, music and so on, with older versions. This could be disastrous.
You also want to preserve your Internet Explorer Favorites, latest passwords,
browsing history and desktop configuration. Therefore, System Restore only
takes a data snapshot of certain items.

Any files stored in your Documents directory will be safe from being replaced
by System Restore. Common personal file extensions (such as .DOC, .HTML,
HTM, . TXT, .JPG, .GIF, .PDF, .MP3, for example) are NOT included in the list
of file types monitored by System Restore, meaning that they should be safe

11
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anywhere on your computer. However, there is a need for slight caution. The
list of included file extensions DOES feature the following types: .EXE, .BAT,
.DLL and many others. Any file of this type will be overwritten with an earlier
version, unless they are inside a directory not monitored by System Restore.

The best advice is to locate any really valuable files inside one or more
subfolders of the Documents folder. The following guidelines may help to
explain some of the less obvious features of System Restore:

* Files with an extension type that is monitored by System Restore will be
restored even if they have been completely deleted from the PC.

* Files that were created (or added) after the date of the restore point are not
deleted by System Restore (even when they are not found in the original
point). However, the restore process will remove any references to them in
the registry.

* Files that were created (or added) after the date of the restore point (and
were subsequently deleted) cannot be recovered using System Restore.

Create a Manual Restore Point with Just 1 Click

The problem with System Restore is that you have to click your way though a
lot of Windows just to be able to create a restore point. Wouldn’t it be great if
you could create a restore point with just one click? Well, you can.

Windows has a built-in tool, the Windows Script Host (WSH), that hosts
programs written in several scripting languages. A script is a program written
in a plain text file, using a tool such as Notepad. This is enabled by default in
Windows but in some situations it can present a security risk, so your security
software might have disabled it.

To check whether the WSH is enabled:

1. Click Start > Run.
2. Type: cmd and press [Enter)

3. When the Command Prompt window opens, type: wscript and press
Enter). If the WSH is enabled, a dialogue box will open. This means that
you can run script files. If no dialogue appears, then WSH is disabled.
There are a variety of ways to disable the WSH. To re-enable it, you will
need to refer to the documentation for the original tool that was used to
disable the WSH.

12
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We will create a script called CREATE_RESTOREPOINT.VBS which will use a
command from the Windows Platform SDK (Software Development Kit) to
create a restore point. The Windows Platform SDK is a programmer’s resource
that includes the latest files, libraries and tools for developing Windows
programs. To create CREATE_RESTOREPOINT.VBS proceed as follows:

1. Right-click on the desktop and then click New > Text Document.
2. Double-click on NEW TEXT DOCUMENT.TXT.

3. When Notepad opens, type in the following:

r n L = T 1
"] Untitled - Notepad "R T [NNERINIENNT TRT SN W ESEE)

File Edit Format View Help

set thisComputer = wWscript.Createobject("wscript.Network™) i
message = "Feeling a bit cautious...manual Restore Point was created by " &
thisComputer. UserName

set restorePoint = getobject ("winmgmts . \roothdefault:systemrestore™)

If (restorePoint.createrestorepoint(message, 0, 100)) == 0 Then

Msgso; "Whoops! Your scripted Restore Point didn't happen!”

End I

e

4. Click File > Save.
5. Click File > Exit.
6. Right-click on NEW TEXT DOCUMENT.TXT and then click Rename.

7. Type: CREATE_RESTOREPOINT.VBS press and confirm that you
want to change the file’s extension.

Now, every time you click on CREATE_RESTOREPOINT.VBS a System
Restore point will be created.

Choose Your Own Schedule for Creating Restore Points

In the last section, you learned how to create a restore point with just one click. To
take this a stage further, it is possible to use Windows Scheduled Task feature to
trigger the same script at regular intervals. Unlike the system checkpoints created
daily by Windows, you can select the frequency of this scheduled restore point
yourself. In addition, this point will be stored even when your PC is not idle (scanner
or anti-virus checker activity can prevent a system checkpoint). To get started:

Windows 7/Vista

1. Click Start > All Programs > Accessories > System Tools > Task
Scheduler.

13
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2. Click Create Basic Task.

SN

0 N O O

. Click Next > Finish.

. Click Next. Select Start a program and click Next.

3. Enter a name for the task (e.g. Create restore point) and click Next.

. Select how often you’d like the task to run, click Next, then configure the
specific details of the days or dates to run the task.

. Browse to CREATE_RESTOREPOINT.VBS on the desktop.
. Select CREATE_RESTOREPOINT.VBS and then click Open.

Configure the

Create Basic Task Wizard

specific dates and B weeny
times that you would

Start:  07/09/2009 [E~

||ke the restore p0|nt Cr.eatEaBasicTask
Trigger
to be created.
Finish -
Click Next
to continue.

[T] Universal time

[] Tuesday [] Wednesday

= Saturday

[ <Back || Nex

] (o)

Automatically create a restore point every week

Windows XP

Scheduled Tasks.

L e

Double-click Add Scheduled Task.
When the Scheduled Task Wizard launches, click Next.

1. Click Start > All Programs > Accessories > System Tools >

Under Click the program you want Windows to run, click Browse.
Browse to CREATE_RESTOREPOINT.VBS on the desktop.
Select CREATE_RESTOREPOINT.VBS and then click Open.

14
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7. Under Type a name for this task, change the name to: Create A
Restore Point.

8. Under Perform this task select daily (you can always change this later).
9. Click Next.

10. Complete a Start time and Start date. To test that this set-up is
working, initially set the Start time for five minutes from the current time
and set the Start date to yesterday’s date (note: it won’t perform the
task if you set it to today’s date).

11. Leave Perform this task set to Every Day.
12. Click Next.

13. Enter your Windows logon password. Note: if your user account has a
blank password, you will need to set one by going to Start > Control
Panel > User Accounts.

14. Click Next > Finish. The scheduled task Create A Restore Point should now
appear in the Scheduled Tasks windows, under Add Scheduled Task.

15. If necessary, you can adjust the Schedule by right-clicking Create A
Restore Point and then clicking Properties > Schedule. You can
check that the task is working by monitoring the Last Run Time column
in the Scheduled Tasks window. You can also go to System Restore
and check that the new restore point is displayed.

So, now you know how to use System Restore to get your PC back up and
running. If you come across any problems in Windows you can easily resolve
them by reverting your system to a previously working configuration. You have
also found out how simple scripting can reduce the effort required to protect
your computer. Hopefully, you are now feeling completely restored!

Whilst Agora Business Publications LLP makes every effort to ensure that the information contained within this publication is
accurate, Agora Business Publications LLP cannot accept any liability for any loss of data or damage to your PC, peripherals or
software as a result of acting or refraining to act on the material contained in this publication. Agora Business Publications LLP
will not accept any liability for any problems arising from the use of any of the information supplied in this publication. Carrying
out any of the procedures contained within this publication confirms your agreement to this condition.
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